Интернет, компьютеры, софт и прочий Hi-Tech

Подписаться через RSS2Email.ru

Обновляем Linux Mint 13 LTS правильно

В конце 2013-го года сборщики «Мяты» сделали пользователям подарок: осуществили адаптацию новых программ для старого доброго Linux Mint 13 LTS — выполнили так называемое бэкпортирование. Видимо, уразумели, что последующие релизы (14-й, 15-й и особенно 16-й) получились удручающими, большинство по-прежнему предпочитает 13-й.

Да и статус «LTS» («Long Term Support») подразумевает наличие реальной поддержки до 2017-го, и через полтора года после выпуска ОС пора бы уже изобразить хоть какую-то полезную активность в решении данного вопроса. Вот и изобразили. Мы же расскажем о нюансах.

Подготовка

  1. Запускаем «Менеджер программ», идём в меню «Правка», дабы отыскать «Источники приложений», и там:
    1. активируем репозиторий Backports, чтобы можно было обрести свежие плюшки;
    2. на второй вкладке (с «другим софтом») выпиливаем репозитории PlayDeb и GetDeb, иначе будут вылезать сообщения об ошибке доступа к серверам;
    3. в эмуляторе терминала производим команду sudo apt-get update, даже если «Менеджер программ» сам себя перезапустил и достоверно изобразил добросовестную попытку скачать сведения о доступных пакетах.
  2. На всякий случай освежаем программу mintUpdate («Менеджер обновлений»).

    освежаем программу mintUpdate («Менеджер обновлений»)

    Иначе она вообще ничего качать не будет. Как говорит Клемент Лефевр, руководитель сборщиков «Мяты», так задумано изначально («by design»). Всё описанное далее, в общем-то, наличия mintUpdate не требует, но данный софт когда-нибудь да пригодится.

  3. Если взяли вариант с Cinnamon (с «Корицей»), а не с MATE, непременно обновите оболочку методом осуществления команды
    sudo apt-get install cinnamon

    Поскольку «из коробки» — ну очень уж старая и глючная версия 1.4. Настолько глючная, что, вероятно, вообще работать не позволит.

Не пытайтесь установить пакет *.deb с Cinnamon, взяв его из кэша на другом компьютере. Gdebi заявит, что от этого половина системы сломается. Хотя в терминале установка проходит совершенно безболезненно — и при обновлении, и рядом с MATE. Таков Linux Mint «by design», что поделать...

Не пытайтесь установить пакет *.deb с Cinnamon

В первую очередь

Самое важное, в любом случае (с любой оболочкой) подлежащее скачиванию немедленно:

  1. свежие версии браузера Firefox и почтового клиента Thunderbird;
  2. офисный комплект LibreOffice, чуточку оптимизированный и с исправленными ошибками;
  3. плагин Adobe Flash, он в установленной начисто ОС тоже старый;
  4. новые кодеки GStreamer вместо имеющихся, воспроизводящих *.mp4 через раз.

Желательно сразу же, без раздумий и колебаний, выпилить нехороший пакет проверки англоязычной орфографии, из-за которого Gdebi не хочет устанавливать браузеры по двойному клику на *.deb (не только Firefox, но и Opera 12.16) — заявляет о неразрешимом конфликте. Поступаем вот так:

sudo apt-get remove hunspell-en-us

Впрочем, при установке с помощью одного лишь терминала всяческие конфликты волшебным способом решаются сами собой. Значит, три пункта обрабатываем одним махом:

sudo apt-get install firefox thunderbird libreoffice mint-flashplugin

С третьим пунктом, то бишь с кодеками, доведётся чуточку повозиться. В смысле, скопировать и вставить в окошко терминала (задействовав меню под правым кликом) вот эту длинную, проверенную на практике команду:

sudo apt-get install gstreamer0.10-plugins-ugly gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad

Новые плюшки

Сначала добавляем программу для форматирования флэшек, а также превращения оных в загрузочные. Такой командой:

sudo apt-get install mintstick

программа для форматирования флэшек USB Stick Formatter

При этом будет удалена абсолютно неработоспособная программа USB Image Writer. (Вернее, фактически будет заменена на иную, но с сохранением названия.)

абсолютно неработоспособная программа USB Image Writer

Если у вас есть *.deb с mintstick (добытый на packages.linuxmint.com), то перед запуском его установки посредством Gdebi следует предварительно выпилить старую USB Image Writer вручную, иначе снова начнутся жалобы на неразрешимые конфликты.

Что ещё из потенциально полезного бэкпортировано в Linux Mint 13:

  1. mintNanny (блокирует нежелательный исходящий траффик);
  2. mintUpload (вдруг кто-то пользуется);
  3. mintUpdate (это менеджер обновлений, с ним уже разобрались).

Плюс приложения, свежие версии которых предоставляются, видимо, исключительно ради количества: mintInstall, mintSystem (их обновлять бессмысленно), mintMenu (это главное меню, оно тормозит сильнее старого!); mintDesktop (улучшений нет никаких); mintWelcome (никому не нужная сущность, напрасно захламляющая экран при старте сеанса).

Хотя, несомненно, кто предпочитает «не отставать от жизни», тем не возбраняется установить вообще всю «свежатину», все шестьсот с копейками мегабайт (посредством mintUpdate). Правда, целесообразность такого действия слегка сомнительна.

Что не лечится

Бессмысленно обновлять Brasero, программу прожига болванок. Все версии стабильно унылые. Лучше использовать Xfburn:

sudo apt-get install xfburn

Иногда глючит, не без этого, но лазерные диски (одноразовые) портит гораздо реже.

Последний (больше не производится) релиз браузера Opera для Linux (настоящего, с движком Presto) пронумерована так: 12.16.1860. Именно она лежит на официальном FTP-сервере Opera Software (ftp.opera.com). Поэтому некая «более новая версия», предлагаемая из маленького собственного репозитория «Мяты» (о чём уведомляет Gdebi), — это нечто самодеятельное. Вероятно, с «поиском Mint» и прочими модификациями.

В версии «Мяты» с MATE по-прежнему не работает Bluetooth. Хотя после обновления оболочки намёки на прогресс есть — периодически удаётся что-то оправить в телефон. Примерно с пятнадцатой попытки. Иногда даже с десятой. Но скачать файлы с microSD телефона не удалось ни разу. Хотя тот же адаптер превосходно функционирует и в Cinnamon, и в Unity.

Говоря коротко, если без Bluetooth не обойтись, с рабочим столом MATE, вероятно, доведётся распрощаться. Поменять на тот же Cinnamon, например.

Заключение

Резюмируем. С целью экономии времени, траффика (если актуально), а также во избежание разочарований из-за несбывшихся надежд, рекомендуется обновлять лишь то, что реально развивается и хоть немножко улучшается (офисный комплект, кодеки, Adobe Flash, браузеры, рабочий стол Cinnamon). Добавлять — только реально функциональное и полезное (mintstick, например).

Всё остальное не внесёт в Linux Mint 13 LTS практически никаких существенных улучшений.

Автор: vanilinkin, специально для xBB.uz, 30.12.2013


Предыдущие публикации:

Биржа долевых инвестиций SIMEX.

Последнее редактирование: 2014-11-14 04:57:23

Метки материала: linux mint 13, софт, mint, обновляем linux, lts, новые программы, мята, программы, linux mint, ос, mint 13, linux, mint 13 lts


5 комментариев

14.11.2014 04:59:32 #
Mozilla Firefox dima
Поправил
13.11.2014 22:50:29 #
Mozilla Firefox Гость Просто гость
При вставке в терминал
Второе install лишнее.
Описка, бывает.
13.11.2014 18:34:47 #
Mozilla Firefox Гость Станислав
При вставке в терминал  "длинной, проверенной на практике команды:sudo apt-get install gstreamer0.10-plugins-ugly install gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad" выдаёт:
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
E: Не удалось найти пакет install
15.01.2014 03:57:48 #
Mozilla Firefox dima
Пожалуйста Well
14.01.2014 11:39:40 #
Opera Гость Sergej
Большое спасибо за статью!!! Mintstick прекрасно пошёл и на Ubuntu, и на Elementary OS.

Оставьте, пожалуйста, свой комментарий к публикации

Представиться как     Антибот:
   

Просьба не постить мусор. Если вы хотите потестить xBB, воспользуйтесь кнопкой предварительного просмотра на панели инструментов xBBEditor-а.


© 2007-2017, Дмитрий Скоробогатов.
Разрешается воспроизводить, распространять и/или изменять материалы сайта
в соответствии с условиями GNU Free Documentation License,
версии 1.2 или любой более поздней версии, опубликованной FSF,
если только иное не указано в самих материалах.